OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#101 - Index bound error in color selector window.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 31 August 2004, 05:21 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 31 August 2004, 06:00 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Low
Priority Normal
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In the color selector window, if the mouse is pressed and the pointer moved out of the window, and exception is raised.

Mouse position should be ignored if is out of the limits of the color-chart bitmap.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Tuesday, 31 August 2004, 06:00 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 31 August 2004, 06:00 GMT-6

The problem is that the gotten TColor is -1 when out of the bitmap.

Functions FNopm_ColorToDecColor and FNopm_ColorToRGB raise the exception when calling GetRValue, GetGValue or GetBValue.

Added a verification just to see if the number is positive.

(Confirmed with information from:
http://homepages.borland.com/efg2lab/Library/Delphi/Graphics/VCLRTL.htm
and
http://www.efg2.com/Lab/ImageProcessing/Magnifier.htm).

Closing this bug.

Loading...