OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#119 - Error when connecting: "is not a valid integer value"

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 14 September 2004, 00:36 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 14 September 2004, 03:05 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Low
Priority High
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When connecting using a full HTTP URL as hostname DB parameter, the following error is shown:
'' is not a valid integer value.



The ZEOSlib builds a kind of database-URL with all database parameters and then it tries to parse it. The problem is that it cannot find each piece and ends up getting the wrong parts. As the port number is mixed with alpha characters, the number conversion raises an exception.


We should clean the hostname to strip all illegal characters.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Tuesday, 14 September 2004, 03:05 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 14 September 2004, 03:05 GMT-6

Fixed (with dumb cleaning).
Closing.

Loading...