OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#123 - Test with WINE.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 21 September 2004, 15:29 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Thursday, 18 February 2010, 15:38 GMT-6
Task Type Test request
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity High
Priority Urgent
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Pending to test compatibility with WINE in Linux.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Thursday, 18 February 2010, 15:38 GMT-6
Reason for closing:  Will not fix / implement
Additional comments about closing:  As we start working in the Lazarus migration, this request is no longer important.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 26 October 2004, 23:17 GMT-6


Tested with SLAX (KillBill beta variante).
It showed an access violation at address 400A5DFB, write on address 45F40000, and a messge: "Failed to set calendar min/max range".

In the product editing window, the availability date is not displayed properly. There was also an error there when trying to save the changes: "Invalid argument to time encode".

Several operations could hang the application with the following error (in the console): err:ntdll:RtlpWaitForCriticalSection section 0x4031001c "?" wait timed out in thread 000a, blocked by 0009, retrying (60 secs). After that, the application was frozen. The moment it ocurred appleared to be random, but always was after clicking the mouse. (Not that the mouse is the cause, but that the activity *after* the mouse click was causing this).

As this version of KillBill is beta.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 26 October 2004, 23:17 GMT-6

Pending to test with Win4Lin.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Friday, 21 January 2005, 16:00 GMT-6

Screenshots of what happened when loading OSCPMWin with Wine in SLAX (KillBill beta edition).

SLAX (slax.linux-live.org) is:
"SLAX is a small bootable CD containing the Linux operating system. It runs Linux directly from the CD without installing. The Live CD described here is based on the Slackware Linux distribution..."

and the KillBill edition of SLAX is:
"SLAX with WINE to run Windows apps".

Comment by Mario A. Valdez-Ramirez (mvaldez) - Saturday, 09 July 2005, 13:53 GMT-6

Tested with SLAX KillBill variant, version 5.0.5.

We received an Access Violation at address 0055F765 in module oscpm1.exe. Read of address 000000B0. This was version 0.1.1.475.

We couldn't pass from that error, the dialog box didn't responded.
Attached is the screenshot.

Loading...