OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#176 - Price and quantity restrictions should apply to module interface.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Sunday, 20 March 2005, 15:50 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Monday, 04 April 2005, 03:58 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Very Low
Priority Immediate
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Data exchanged with external modules should be restricted the same way user-received data is.

For example, zero prices and negative quantities.

Expected behavior:
If zero prices are disallowed by the configuration, exchanged data with the external modules should mark zero prices as exchange errors.
The same for negative quantities.

This may apply to other data exchanged with external modules.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Monday, 04 April 2005, 03:58 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Sunday, 20 March 2005, 15:51 GMT-6


changing severity to Critical, as this problem may cause data loss.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Monday, 04 April 2005, 03:17 GMT-6

Fixed.

Not yet closed.

This fix will follow the restriction, but it won't give a clue to the user about ignored or not-ignored values.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Monday, 04 April 2005, 03:58 GMT-6


Now it is fixed for real.

The sync listing will display a warning icon for those items that cannot be synchronized because of configuration restrictions.

Also, we added a menu option to copy only those items to the clipboard.

Closed.

Loading...