OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#180 - Non-translated strings are marked with an asterisk.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Wednesday, 23 March 2005, 06:55 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Friday, 02 September 2005, 13:37 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Low
Priority High
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Non-translated items are marked with a leading asterisk in the language files. That asterisk is to be used by translators and reviewers to let them know what items still need their attention.

However, the asterisk is being shown in the running application, which is not useful for the end-user and may actually be misleading.

Expected behavior:
Don't show that asterisk.
Strip it in the main application.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Friday, 02 September 2005, 13:37 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Thursday, 01 September 2005, 15:29 GMT-6


This problem is caused by a prior coding decision. We decided to use coded captions and hints. For example, if the control was named opm_Edit_pedit_netprice, the caption actually contained only the "opm_Edit_pedit_netprice" string, and the Hint property was set to "opm_Edit_pedit_netpriceTip". This allowed us to set the string to whatever we liked and allowed us to decide the proper naming (the tagging) after we write the code.

The problem is that, because "opm_Edit_pedit_netprice" is too cryptic we needed to include the English translation in each language file. So, if the English caption was "Net price", in the Spanish, Russian, Italian, etc. language files we should add "Net price" too, or the translator (and reviewers) would not know what "opm_Edit_pedit_netprice" means. To mark the string as untranslated we added the asterisk. (In a normal situation [without using coded names], the poEdit editor would mark those strings as unstranslated.

What we should do is to convert all coded captions and hints to the normal English string. And then convert all .po files.

We already have tested some scripts.

Comment by Mario A. Valdez-Ramirez (mvaldez) - Friday, 02 September 2005, 13:37 GMT-6

Fixed (sort of).

Several translations are now tagged as fuzzy translations. The translators need to review again the .po files. The translation rates lowered after this change.

Closing.

Loading...