OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#185 - ASPEL synchronization module crashing and hanging.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Thursday, 07 April 2005, 06:23 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Thursday, 07 April 2005, 06:29 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Low
Priority Immediate
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The 0.0.3.xx versions crashed unexpectively under not-so-well-defined circunstances. The program crash with an access violation error and sometimes with an error on a DAO dll. Also, sometimes it crashed with an EOSError (code 1400).
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Thursday, 07 April 2005, 06:29 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Thursday, 07 April 2005, 06:29 GMT-6


There were several problems with the 0.0.3.xx version of the module that are now fixed in 0.0.4.xx.

First, the critical sections were not defined globally. That caused unexpected access violations when accessing the VCL GUI components (which are not thread-safe).

Second, one parameter in three functions regarding a DAO table were not being passed by reference. That caused the DAO dll error, also in unexpected ways (some kind of queries triggered it, others did not).

The EOSError is caused by a thread referencing a VCL component (maybe GUI, maybe DAO) that no longer existed (because of the crashing). This error may appear again, as the module doesn't have still any termination-handling code. But as long as no crashing occurs, it won't happen (because the progran don't exit unless the last thread has terminated).


Loading...