OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#190 - Deleting productt does not delete the product descriptions records.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Monday, 11 April 2005, 08:00 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Sunday, 15 July 2007, 01:33 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Medium
Priority High
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When deleting a product, only the record in the products database is deleted. The records in all other prdouct-related tables are left intact.

Expected behavior:
All data related to a given product should be deleted when the main record of the product is deleted.

OSCommerce seems unaffected by the orphan records.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Monday, 11 April 2005, 08:14 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Monday, 11 April 2005, 08:08 GMT-6


Very sloppy programming. It seems we are not deleting even those records we add when creating a product: description, special price and cat-to-prod relation.

Fixing it.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Monday, 11 April 2005, 08:14 GMT-6


Fixed by deleting what we create. However, unsupported tables (even standard tables of OSCommerce) are not modified.

Closing.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Monday, 11 April 2005, 08:21 GMT-6

Reopening.

After reviewing the deletion procedure followed by OSCommerce, we have decided to implemente the following cleaning steps (besides those already taken):

Delete from table products_attributes.
Delete from table customer_basket.
Delete from table customer_basket_attributes.
Delete from table reviews.
Delete from table reviews_description.



Comment by Mario A. Valdez-Ramirez (mvaldez) - Monday, 11 April 2005, 08:22 GMT-6


We are deferring because OSCPMWin currently does not know anything about those tables. We need to include the references and handling code (including configuration).

So, Deferred.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Sunday, 15 July 2007, 01:33 GMT-6
This bug depended on Bug #344, to retrieve the names of the database tables.

Loading...