OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#220 - Add warning if current editing data is too old.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Thursday, 07 July 2005, 13:18 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Saturday, 16 July 2005, 22:19 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Medium
Priority Immediate
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The data managed by the application is not really 100% current data. From the time the data is fetched from the SQL server to the moment the user press "Ok" (or whatever control is available) to update the data in the server, the server data could have changed.

I the user load a product listing and waits several hours, then edit the data of a product, the data in the server may have changed. For example, the products in stock could have changed. For most operations, this is not important unless there are several users trying to edit the same products at the same time.

Critical data usually is only stock (because is forbidden to charge a credit card if the product is not really in stock).

A warning should be displayed if the displayed data is too old. Maybe a few minutes.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Saturday, 16 July 2005, 22:19 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Saturday, 16 July 2005, 22:19 GMT-6

This bug is related to Bug #221, or maybe we should considere it a duplicate of it.

We will close this one as "will not fix" to favor the implementation of the suggested solution of Bug #221.



Loading...