CMS module for Phprojekt

CMS module for Phprojekt
Tasklist

FS#28 - Compact and Mojo themes licensing vs copyright note in files

Attached to Project: CMS module for Phprojekt
Opened by Mario A. Valdez-Ramirez (mvaldez) - Friday, 02 July 2004, 03:27 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 06 July 2004, 08:45 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Very Low
Priority Immediate
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The compact and mojo themes by Mark Coudriet are released under a double-license (GPL and LGPL) but some legends in the source code keep the copyright note of the CMS4P module.
The CMS4P module is released only as GPL (because link directly to Phprojekt lib code which is GPL only) and cannot be changed to LGPL.
The easier solution is to change the copyright notes so the holder is Mark Coudriet, who can release them under any license he wants.
To avoid future copyright claims (not from me, of course, but who knows if I die what will happen) Mark should state "based on code by MAVR... etc".
A more complete solution would be to release those files to Mark Coudriet under LGPL so he can tag them with any legend (GPL or LPGL).
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Tuesday, 06 July 2004, 08:45 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Saturday, 03 July 2004, 18:06 GMT-6
Waiting for answer from Mark Coudriet.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Monday, 05 July 2004, 11:52 GMT-6
Mark clarified the copyright/licensing issue.
All files from his themes will contain the legend that he is the copyright holder. All files coming from other sources will be tagged as such. All files with LGPL license will be turned to GPL.
The problem is the Mojo image files, they are not being released under GPL/LGPL, but other propietary license. We cannot distribute them with the CMS module.

We need to check that with Mark and/or the author of the image files. An alternative would be to provide the files as a separate download, but need to check carefully the terms of the original author. Or we can provide a link to Mark's site or we can provide a link to the author's site (just like we did before with other CMS icons).
Comment by Mario A. Valdez-Ramirez (mvaldez) - Tuesday, 06 July 2004, 08:44 GMT-6
Fixed. Compact files will be included. Mojo files will not, as its license is non-GPL compatible.

Loading...