OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#294 - Error messages about server-side script are uninformative.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Sunday, 06 November 2005, 05:18 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Saturday, 19 November 2005, 16:17 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Low
Priority Immediate
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When connecting, the application first send a NOOP operation request to the server-side script to check:

It can connect to the web server.
It can find the server-side script.
The script version is correct.
The connect password is correct.

The problem is, the error message is the same for any problem. The application should display a very specific error message, not a generic one for all possible errors.

This bug has increased the incoming emails and postings about errors connecting to the server. It should be fixed right now.

Severity: Major.
Priority: High.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Saturday, 19 November 2005, 16:17 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Sunday, 13 November 2005, 03:44 GMT-6
We have changed the values returned by FNopm_Send_Command so that it returns also an error code regarding the cause of the problem. Previously, it only returned TRUE or FALSE and an empty return string.
Comment by Mario A. Valdez-Ramirez (mvaldez) - Saturday, 19 November 2005, 16:17 GMT-6

Fixed.
Closed.

Loading...