OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#334 - Check for first available language before loading categories.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Sunday, 16 April 2006, 03:05 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Monday, 14 May 2007, 07:46 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Low
Priority Immediate
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

One user sent a bug report about the category tree being empty when connecting to the server. After checking his database and replicating his store, I found out that the category tree was empty because OSCPMWin tried to load the categories with language_id=1 (which is English in a fresh install of osCommerce) even if there is not language 1 in the store.

The user only needed to select the correct language from the language menu in the toolbar and then everything would be fine. Even the next time, the application would load the category tree fine, because it would try to load the last used language.

Expected behavior: the application should check the list of available languages, then choose the first one to load the rest of the lists, including the category tree.

High priority, minor severity.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Monday, 14 May 2007, 07:46 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Monday, 14 May 2007, 07:46 GMT-6
in the PRopm_LoadLanguageList procedure at main.pas, the current language is set to opmC_Def_DisplayLang if the current language is not valid (which is not valid the first time we connect).

Closing as Fixed.

Loading...