OSCommerce Product Manager

OSCommerce Product Manager for Windows
Tasklist

FS#72 - Availability date header is not being localized.

Attached to Project: OSCommerce Product Manager
Opened by Mario A. Valdez-Ramirez (mvaldez) - Saturday, 21 August 2004, 10:03 GMT-6
Last edited by Mario A. Valdez-Ramirez (mvaldez) - Saturday, 11 September 2004, 20:09 GMT-6
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To Mario A. Valdez-Ramirez (mvaldez)
Operating System All
Severity Very Low
Priority Normal
Reported Version any
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The column "Availability date" is not being localized when changing to Spanish language controls.

The translation is available in the GNUGetText files.

Pending check the cause.
This task depends upon

Closed by  Mario A. Valdez-Ramirez (mvaldez)
Saturday, 11 September 2004, 20:09 GMT-6
Reason for closing:  
Comment by Mario A. Valdez-Ramirez (mvaldez) - Saturday, 11 September 2004, 20:09 GMT-6

The cause was that the string to be translated was "AvailDate", but when changing languages, dxgettext was looking for the translated string "Availability Date", which was not found in the language files.

This happens because the columns names are translated once when created from the internal name (AvailDate), but later then are translated from the translated string (Availability Date).

The fix was to set the internal (unstranslated) string to "Availability date", and then adding the string to the language files.

Fixed.
Closed.

Loading...